Degraded Performance
Incident Report for Nexus Transport Group
Resolved
This has now been resolved, sorry for any inconvenience.
Posted Apr 16, 2022 - 14:00 UTC
Investigating
We're currently investigating slow speeds on our Website and Dashboard at this moment in time, we will provide updates every few hours.
Posted Apr 14, 2022 - 20:54 UTC
This incident affected: Nexus Transport | Website and Nexus Dashboard | Website.